MSEndpointMgr
Home » Microsoft Endpoint Manager » ConfigMgr » Operating System Deployment » ConfigMgr OSD FrontEnd – Version 1.4.0 released

ConfigMgr OSD FrontEnd – Version 1.4.0 released

We’re proud to announce the release of ConfigMgr OSD FrontEnd version 1.4.0.

Download

More information about ConfigMgr OSD FrontEnd is available on the following page, including download link and release notes:

ConfigMgr OSD FrontEnd

What’s new

Below is a list of enhancements and new features made available in this release:

  • New Directory section has been added with a tree view of all organizational units available in the domain where the ConfigMgr WebService is installed. Control whether this section is shown by setting IsDirectoryEnabled to True. Selecting an organizational unit in this section adds the distinguished name to the task sequence variable specified in DirectoryOUVariableName, default using the OSDDomainOUName variable.
  • When validating computer names, a message prompt with validation results are now shown instead of the previously colored outline of the text.
  • When validating a computer name, support for multiple domains are now available. This is handled backend in the ConfigMgr WebService.
  • Fixed a bug that would cause the Previous and Next buttons to be shown even though that the pre-flight checks were not successfully passed.
  • New Custom section is added to the frontend. This section is intended for building custom task sequence variables based upon either their existence or a value that is manually set in the frontend.
  • Computer name text field can now be locked using the ComputerNameLock application configuration setting with a value of True.
  • Fixed a bug in the Authenticate section that would give an error like “The server cannot handle directory requests.””. Extended PowerShell script for auth with [System.DirectoryServices.AccountManagement.ContextOptions]::Negotiate if failed without”.
  • Frontend will now show an error message if IsAuthenticationEnabled is set to False and DeployRestricTaskSequenceSelection is set to True. This is to prevent misconfiguration in the OSDFrontEnd.exe.config file when the frontend has been configured to restrict the shown task sequences, but authentication has not been enabled, which is a requirement for that feature.
  • Fixed an issue that would cause the frontend to crash when multiple elements existed in the RegionalConfig.xml file that contained the same Name attribute value.
  • You can now customize the text for the Apply button using ButtonApplyName.
  • The authenticated user in the Authenticate section is now stored in task sequence variable named OSDAuthUser.
  • A new data grid is added to the Deployment section showing the selected task sequence details like description and more.
  • Fixed an issue in the User section where the value of SMSTSUdaUsers was not set correctly.
  • User section text field now has an increased length of characters. This was previously 15 and has now been set to 20.
  • A new application configuration setting named AppsMandatoryLock has been added, allowing for applications specified in the AppsMandatory setting to be de-selectable. With this new feature you can automatically pre-select applications in the Apps section but allow for the end-user to deselect them.
  • You can now group select multiple applications in the Apps section with a single click in addition to that applications are alphabetically sorted. New icons have also been added to each item in the tree view.
  • Due to some minor design changes, the logo size has been modified and is now 353 x 136 px.
  • Combo boxes throughout the frontend has been limited to show within the bounds of the application.

Dependencies

ConfigMgr OSD FrontEnd 1.4.0 requires ConfigMgr WebService 1.6.0. You can download ConfigMgr WebService from below:

ConfigMgr WebService 1.6.0

Documentation and usage

Embedded in the download package for ConfigMgr OSD FrontEnd is a PDF file called ConfigMgr OSD FrontEnd 1.4.0 – Documentation. This file contains all the information regarding how to get started, detailed explanation of how to use the frontend and some tips and tricks.

(6388)

Nickolaj Andersen

Chief Technical Architect and Enterprise Mobility MVP since 2016. Nickolaj has been in the IT industry for the past 10 years specializing in Enterprise Mobility and Security, Windows devices and deployments including automation. Awarded as PowerShell Hero in 2015 by the community for his script and tools contributions. Creator of ConfigMgr Prerequisites Tool, ConfigMgr OSD FrontEnd, ConfigMgr WebService to name a few. Frequent speaker at conferences such as Microsoft Ignite, NIC Conference and IT/Dev Connections including nordic user groups.

18 comments

  • We are using FrontEnd version 1.4.0 and WebService 1.6.0 and the PC Name does not work on new devices. It names it minint-…… even when you put the name in the field. Any suggestions?

  • Hello Nickolaj,

    I’ve gone over the entire PDF 3x. All is working except for the Task Sequence selections. There’s no list. The drop-down doesn’t show anything. If I run osdfrontend.exe debug from the SCCM server then the list populates with Task Sequences. I’ve double-checked pxe and hidden are set on the TS. These TSes are the ones that show up in the list. If I go onto a different computer and point to the UNC path of the files located on the SCCM server and run osdfrontend.exe debug the TS list is blank.

    I really do appreciate all that you’ve done with this project. It’s awesome!

    I’m just trying to get this last piece to work.

    Thank you,

    Brian

  • Hi Nickolaj,

    Just wondering how to get the computer name from the asset tag instead of a serial number in BIOS, I’m a newbie to the web services, any directions will be appreciated. Thanks

  • Hello,Nickolaj.
    Thank you for this usefull tool ,It will resolve the pain point in dealing with unknown computer deployment.
    But when I boot in a unknown device,I can’t find any tasksequence,and I don’t know WHY.I opened only “Computer ” and “Deployment” two parts.And I’m sure the ConfigMgr web service works well.Below is my OSDFrontEnd.exe.config file.

    sccmpxe

    Apply

    Regional

    False

    False

    False

    False

    True

    True

    True

    True

    True

    True

    True

    False

    False

    True

    True

    UUID

    False

    Windows 10 Enterprise 1511 x64 – Install

    False

    https://sccm-server.test.com/DeployConfig.xml

    https://sccm-server.test.com/RegionalConfig.xml

    https://sccm-server.test.com/AppConfig.xml

    Notepad++
    7-Zip 9.20

    True

    APPLICATION

    OSDDomainOUName

    True

    True

    True

    True

    https://sccm-server.test.com/HWModels.txt

    30000

    admin

    Blue

    BaseLight

    Welcome Title

    This would be the welcome dialog message.

    2046820353

    2046820352

    powershell.exe

    -ExecutionPolicy Bypass -File .\PrestartCommand.ps1

    OSDFrontEnd Users

    corp.domain.com
    uat.domain.com

    This text is read from CustomDescriptionText application setting

    https://sccm-server.test.com/CustomConfig.xml

    Custom

    • Hi James,

      I’m truly unsure why that’s would not work. Have you gone over the documentation PDF included in the package you download and made sure you’ve setup everything as it requires including making the deployments hidden?

      Regards,
      Nickolaj

  • I have the front end up and running, however I’m unable to see my task sequences under the deployment tab. I’ve tried to restrict access as well and use the delpoy.xml file, but I didn’t have any luck with this route either. Any idea on where to go from here?

    • I have the same problem… Everything populates BUT the drop down for Task Sequence in Deployments

  • HI, how and if can i change the order of the tabs? Can i rename tabs? Is there an option to populate apps list based on entries in previous tabs (i.e role)

  • Hello!

    I got some issues with the FrontEnd, when you are suppose to select the TS under Deployment the list is empty for me when trying to deploy a machine that is already registered in the MDT, although i have deployed the TS with Only media and PXE (hidden). Although if i kill the FrontEnd and the regular TS search continues the TS pops up and i can install it, any suggestion on what the problem could be?

  • Hi,

    I have just upgraded the fronted to 1.4 (with the 1.6 version of the webservice). Now when I use the front end I get the following error message:

    Custom config file
    Unable to load configuration file for custom tasks

    I click OK and the computer reboots.

    Just wondering if you have seen this? I have gone through all the FrontEnd files and cannot any reference.

    Regards
    Michael

  • Hi Nickolaj,

    Love your work. Was just wondering if it would be easy to export this section from the OSDFrontEnd.exe.config file and have it as a standalone .xml file that can be stored on the OSDWebfront end server like with appconfig.xml or Deployconfig.xml files

    Adobe Acrobat Reader>
    Java 8
    Java 8(64-Bit)
    CutePDF
    Symantec.Cloud SmartConnect
    Office365 Base Installation

    The idea around this is what is mandatory today may not be mandatory tomorrow so we would like to easily modify this part without having to reconfigure/recreate the boot disk. As a noobie im googling it as i type this but any assistance would be greatly appreciated.

    Thanks in advance

  • Wondering if you could provide any insight on this error when I run OSDFrontEnd.exe debug. The message I receive is “Unable to load configuration file for regional settings”.

    • If you have not found it yet you need to edit the OSDFrontEnd.exe.config, add your server name in the address and create a file there on your web server. Or remove the section from the config file should work too.

      • So, if the RegionalConfig.xml file is more or less empty or contains anything else than XML data? I’ll give that a try and I believe that I’ve not encountered for that, since I ship an example XML with proper formatting, figured that would be enough. Thanks for reporting this!

        Regards,
        Nickolaj

  • I’ve been trying to get the user section to work for the past 2 sections, and I have been unsuccessful. In this new version, when I type in sAMAccountName, I see “Attempting to locate specified user” for about 30 seconds, and then the application crashes.

    It would be helpful to know what requests are happening there. Invoking the GetCMUser web request does work properly. One thing that may be related is that some of the WebService functions fail. For example, GetADGoupsByUser fails for users with too many group memberships, but works for users with few group memberships. Also, GetCMPrimaryDeviceByUser fails, but GetCMPrimaryUserByDeviceName works properly.

Sponsors

Subscribe

Do you want to be notified of new posts on our site?

Please enter your email address below:

Categories

MSEndpointMgr.com use cookies to ensure that we give you the best experience on our website.